Ready > lebih dari 185 Video Tutorial Mikrotik Basic - Mahir disertai Modul

Jadwal Training Mikrotik Bulan ini 09,10,11 Agustus (Basic-Mahir) 3 Hari

Jadwal Training Mikrotik Bulan ini 09,10,11 Agustus  (Basic-Mahir) 3 Hari
Materi Utama : Konsep Jaringan, Setting Gateway, Bandwidth Management, DHCP Server, Static Mapping, Firewall, Scripting & Sheduler. Hotspot & User Manager, Membuat Sistem Voucher dan virtual AP, Mangle, Static Routing, VPN, Load Balancing & Fail Over. Konsep dan Praktek Point To Point dan Point To Multi Point.

Excel Fundamental, Excel Advanced, Dan Excel Programming VBA

IT Course, IT Tutorial, IT Solution, In House Training dan Online Training IT

Memahami Jenis NAT Source NAT (Srcnat) dan Destination NAT (dstnat) di Mikrotik


Pengertian NAT (Network Address Translator) menurut wikipedia adalah suatu metode untuk menghubungkan lebih dari satu komputer ke jaringan internet dengan menggunakan satu alamat IP. Metode ini digunakan karena ketersediaan alamat IP yang terbatas, kebutuhan akan keamanan (security) jaringan lokal, dan kemudahan serta fleksibilitas dalam administrasi jaringan.

NAT bekerja dengan mengalihkan suatu paket data dari suatu alamat IP ke alamat IP lainnya. Ketika suatu paket dialihkan maka NAT akan mengingat dari mana asal paket dan kemana tujuan paket itu. Dan ketika ada paket kembali maka NAT akan mengirimkannya ke asal paket. Dengan kata lain host hanya akan menerima paket yang dikirim atau yang dimintanya sehingga komunikasi dapat berjalan dengan baik.



Jaringan lokal (LAN) yang menggunakan NAT disebut dengan natted jaringan. Di MikroTik NAT dapat digunakan untuk komunikasi internal dan komunikasi eksternal. Maksudnya pengalihan data dapat dilakukan untuk paket yang berasal dari jaringan natted (internal) ke jaringan luar (eksternal) atau dari jaringan luar menuju jaringan natted. Atau kita sebut saja komunikasi dua arah dari dan ke jaringan natted (internal).

Di Mikrotik ada dua jenis NAT:
1.       srcnat (Source NAT) : pengalihan dilakukan untuk paket data yang berasal dari jaringan natted. NAT akan mengganti alamat IP asal paket dari jaringan natted dengan alamat IP publik. Source NAT selalu dilakukan setelah routing sebelum paket keluar menuju jaringan. Masquerade adalah contoh dari srcnat.
2.       dstnat (Destination NAT) : pengalihan dilakukan untuk paket data yang menuju jaringan lokal. Ini biasa digunakan untuk membuat host dalam jaringan lokal dapat diakses dari luar jaringan (internet). NAT akan mengganti alamat IP tujuan paket dengan alamat IP lokal. Destination NAT selalu dilakukan sebelum routing saat paket akan masuk dari jaringan. Port ForwardPort Mappingtransparent proxy adalah contoh dari dstnat.

Contoh Penggunaan NAT Pada MikroTik
Source NAT

Jika ingin menyembunyikan jaringan private LAN kita dengan alamat IP 192.168.2.0/24 dibelakang satu alamat IP 110.137.17.43 yang diberikan oleh ISP, kita dapat menggunakan fitur source NAT dengan action masqueradeMasquerade akan mengubah alamat IP dan port asal (source port) dari paket yang berasal dari jaringan 192.168.2.0/24 ke alamat IP 110.137.17.43 sebelum paket keluar dari router.

Contoh aturan yang dapat kita pakai adalah seperti ini:
/ip firewall nat add chain=srcnat action=masquerade out-interface=public

Seluruh koneksi yang keluar dari jaringan 192.168.2.0/24 akan memiliki satu alamat IP yang sama yaitu 110.137.17.43 dan asal port diatas 1024.

Destination NAT

Jika kita ingin menghubungkan satu alamat IP lokal 192.168.2.30 agar dapat diakses dari jaringan internet melalui IP publik 110.137.17.43, maka kita dapat menggunakan fitur destination NAT.

Pertama tambahkan dulu IP address publik ke interface publik:
/ip address add address=110.137.17.43/32 interface=publik

Lalu buat aturan dengan destination NAT yang memungkinkan server internal dapat diakses:
/ip firewall nat add chain=dstnat dst-address=110.137.17.43 action=dst-nat to-address=192.168.2.30

Kebalikannya buat juga aturan yang memungkinkan server internal dapat berbicara dengan jaringan luar yang akan diterjemahkan ke IP 110.137.17.43:
/ip firewall nat add chain=srcnat src-address=192.168.2.30 action=src-nat to address=110.137.17.43

Nah, dengan begini setiap paket yang menuju jaringan lokal melalui alamat IP publik 110.137.17.43 akan dialihkan ke alamat IP lokal 192.168.2.30. Begitu juga sebaliknya setiap paket yang berasal dari alamat IP lokal 192.168.2.30 akan diganti dengan alamat IP publik 110.137.17.43, jadi IP publik yang akan meneruskan paket dari 192.168.2.30 ke jaringan internet.

Mapping 1:1


Jika kita ingin menghubungkan IP publik dengan subnet 11.11.11.0/24 ke lokal dengan subnet 192.168.2.0/24, kita dapat menggunakan destination NAT dengan action netmap. 

Berikut contoh penggunaannya:
/ip firewall nat add chain=dstnat dst-address 11.11.11.0/24 action=netmap to-address=192.168.2.0/24
/ip firewall nat add chain=srcnat dst-address 192.168.2.0/24 action=netmap to address=11.11.11.0/24

Port Mapping


Kita juga dapat mengalihkan permintaan port tertentu ke server internal di dalam jaringan. Atau hal ini sering disebut dengan membuka port:

Berikut caranya:
/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 in-interface=local action=dst-nat to-address=192.168.3.1 to-port=80

Perintah diatas akan mengalihkan semua paket yang menuju port 80 dengan protokol tcp yang masuk melalui interface local ke alamat IP 192.168.3.1 port 80.

Port Porwarding


Port Forward adalah feature dari router dimana fungsi ini akan membuka akses terhadap perangkat pada jaringan lokal untuk bisa diakses dari internet. Fungsi ini mirip dengan DMZ, bedanya adalah port forwarding hanya akan membuka akses sesuai dengan port yang dibuka dan bisa digunakan terhadap beberapa IP, sedangkan DMZ akan membuka seluruh port sebuah IP lokal untuk bisa diakses dari internet dan hanya bisa membuka satu iplocal saja (satu perangkat).
 

Syntak 


/ip firewall nat add chain=dstnat dst-address=69.69.69.69 protocol=tcp dst-port=5900 action=dst-nat to-addresses=192.168.1.101 to-ports=5900



Share

Artikel Lainnya :



No comments:

Post a Comment

Training Bulan ini

Padepokan IT

Jl. Ciuyah No.45 RT.05/RW.10 Bandung Barat 40551

Telp : 0812 8310 4119 (Telkomsel)
W.A : 081214518859 (WhatsApp)
Website : www.padepokanit.com
E-Mail : padepokanit.course@gmail.com
Instagram : @padepokanit

Info Site

User Online Padepokan-IT Course

IT Tutorial, Training & IT Solution