VIDEO TUTORIAL MIKROTIK TOTAL 200 VIDEO + MODUL TRAINING + SCRIPT

Jadwal Training Mikrotik Bulan ini 11,12,13 Oktober (Basic-Mahir) 3 Hari

Jadwal Training Mikrotik Bulan ini  11,12,13 Oktober (Basic-Mahir) 3 Hari
Materi Utama : Konsep Jaringan, Setting Gateway, Bandwidth Management, DHCP Server, Static Mapping, Firewall, Scripting & Sheduler. Hotspot & User Manager, Membuat Sistem Voucher dan virtual AP, Mangle, Static Routing, VPN, Load Balancing & Fail Over. Konsep dan Praktek Point To Point dan Point To Multi Point.

Excel Fundamental, Excel Advanced, Dan Excel Programming VBA

IT Course, IT Tutorial, IT Solution, In House Training dan Online Training IT

Setting Load Balancing Dengan Metode Pcc Dan Failover Di Mikrotik


Load balance pada mikrotik adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi. Dimana Load Balancing merupakan sebuah metode pembagian beban traffic pada 2 atau lebih WAN dengan tujuan optimasi bandwidth dan meminimalisir terjadinya bootleneck. Misal, jika kita memiliki 2 buah koneksi internet (ISP) yang masing-masing bandwidthnya adalah 512 kbps dan 256 kbps maka bandwidth yang di dapat adalah 512 kbps + 256 kbps = 512 kbps + 256 kbps bukan 512 kbps + 256 kbps = 768 kbps

Kenapa demikian? karena secara fisik load balancing akan tetap menggunakan 2 buah link bukan menggabungkannya menjadi 1 link. 

Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga.

Sedangkan Failover merupakan sebuah metode yang digunakan untuk mengantisipasi terjadinya downtime jika suatu koneksi mengalami gangguan. Artinya Teknik Failover adalah suatu teknik jaringan dengan memberikan dua jalur koneksi atau lebih dimana ketika salah satu jalur mati, maka koneksi masih tetap berjalan dengan disokong oleh jalur lainnya. Teknik failover ini cukup penting ketika kita menginginkan adanya koneksi jaringan internet yang handal.

Asumsi
1.       Koneksi Internet Menggunakan 2 ISP (ISP 1 Firstmedia dan ISP 2 Modem 3G)
2.       Koneksi Internet Dialup Melalui Modem, dan Mikrotik Berfungsi hanya Melewatkan Saja (IP – Route)
3.       Ether1 dan Ether2 Terhubung ke WAN dan Ether3 Terhubung ke LAN
4.       IP Modem 1 : 192.168.1.1 (Modem 3G), IP Modem 2 : 192.168.2.1 (First Media) dan IP Segmen Jaringan LAN : 192.168.10.0/24 dengan Gateway 192.168.10.1/24

Langkah Konfigurasinya adalah sbb :

1.       Set IP address untuk masing-masing ethernet.
/ip address
add address=191.168.1.2/24 interface=ether1-WAN-1 comment="WAN1"
add address=192.168.0.2/24 interface=ether2-WAN-2 comment="WAN2"
add address=192.168.10.1/24 interface=ether3-LAN comment="LAN"



2.       Selanjutnya buatlah rule pada mangle untuk menandai traffic dari ISP1 dan ISP2

/ip firewall mangle
add chain=input in-interface=ether1-WAN-1 action=mark-connection new-connection-mark=traffic-wan1
add chain=input in-interface=ether2-WAN-2 action=mark-connection new-connection-mark=traffic-wan2



3.       Masih pada mangle, buatlah rule untuk menandai traffic yang keluar agar dapat dialihkan ke masing-masing gateway.

add chain=output connection-mark=traffic-wan1 action=mark-routing new-routing-mark=to-wan1
add chain=output connection-mark=traffic-wan2 action=mark-routing new-routing-mark=to-wan2




“Fungsi script di atas (Point 2 dan 3) adalah agar paket yang sudah melewati ISP A maka pulang pergi harus melewati ISP 1, begitu juga dengan paket yang melewati ISP 2”.


4.       Selanjutnya buatlah rule untuk mengizinkan traffic yang datang dari lan mengakses ke wan.

add chain=prerouting dst-address=192.168.1.0/24 action=accept
in-interface=ether3-LAN

add chain=prerouting dst-address=192.168.2.0/24 action=accept
 in-interface=ether3-LAN

5.       Konfigurasi Selanjutnya menentukan konfigurasi dari pcc nya. Karena pada chain prerouting semua traffic akan di tangkap, maka kita tambahkan dst-address-type=!local agar traffic dari lan yang menuju ke ip pada ethernet router akan dihiraukan. Sisanya traffic yang melewati router itu sendiri akan di kelompokan menjadi 2 grup berdasarkan source, port dan destination.

add chain=prerouting dst-address-type=!local in-interface=ether3-LAN per-connection-classifier=both-addresses­-and-ports:2/0 action=mark-connection new-connection-mark=traffic-wan1 passthrough=yes

add chain=prerouting dst-address-type=!local in-interface=ether3-LAN per-connection-classifier=both-addresses­-and-ports:2/1 action=mark-connection new-connection-mark=traffic-wan2 passthrough=yes




6.       Selanjutnya kita buat rule untuk menentukan paket data yang keluar dan masuk agar melalui gateway yang sesuai.

add chain=prerouting connection-mark=pcc-traffic-wan1 in-interface=ether3-LAN action=mark-routing new-routing-mark=to-wan1
add chain=prerouting connection-mark=pcc-traffic-wan2 in-interface=ether3-LAN action=mark-routing new-routing-mark=to-wan2


“Fungsi Script di atas (Point 5 dan 6) adalah, menandai koneksi yang sudah di tentukan berdasarkan classifier dan membuat routing mark berdasarkan koneksi yang sudah di bua”t.


HASIL AKHIR MANGLE

 

7.       Sampai disini kita sudah selesai menandai packet, selanjutnya buat masing-masing routingannya.

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=jalur-wan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=jalur-wan2 check-gateway=ping

“Fungsi Script di atas untuk memasukkan default route berdasarkan routing mark yang sudah di tentukan. Artinya. Pada konfigurasi diatas kita telah  membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masih terhubung”




8.       Konfigurasi Terakhir Buat failover-nya.

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping




9.       Langkah terakhir kita tambahkan rule nat untuk menggunakan kedua linknya.

/ip firewall nat
add chain=srcnat out-interface=ether1-WAN-1 action=masquerade
add chain=srcnat out-interface=ether2-WAN-2 action=masquerade



10.   Lakukan Ujicoba

1.       Dengan cara memutus salah satu ISP, Apakah Client Masih Bisa terhubung ke Internet atau Down
2.       Melakukan Download File dengan cara melakukan 1 file download (1 koneksi), dan Download dengan Beberapa Koneksi (Lebih dari 1 file yang di download)

Hasilnya Terlihat Pada Gambar dibawah ini

KEDUA INTERFACE SUDAH BERJALAN TX DAN RX NYA
 
PENGUJIAN LOAD BALANCING 2 ISP


Kesimpulan & Catatan
1.   Load Balance MikroTik umumnya diterapkan ketika kita mempunyai 2 link network atau lebih, bertujuan untuk membagi  beban traffic data melalui 2 link atau lebih dan disebarkan secara seimbang atau rata.
2.       Load balancing sangat baik digunakan pada saat sebuah server telah memiliki jumlah user yang telah melebihi maksimal kapasitasnya. Load balancing juga mendistribusikan beban kerja secara merata di dua atau lebih komputer, link jaringan, CPU, hard drive, atau sumber daya lainnya, untuk mendapatkan pemanfaatan sumber daya yang optimal.
3.      Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi.
4.       Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal.
5.   Disaat Load Balancer menerima permintaan layanan dari user, maka permintaan tersebut akan diteruskan ke server utama. Biasanya Load Balancer dengan pintar dapat menentukan server mana yang memiliki load yang lebih rendah dan respons yang lebih cepat.
6.    Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.

DOWNLOAD FILE PDF


Sumber Refrensi:

§  Hasil Implementasi Dilapangan Menggabungkan ISP Speedy dan Modem 3G



 Selamat Mencoba

SALAM PADEPOKAN IT COURSE




Share

Artikel Lainnya :



6 comments:

  1. bisa gak saya kursus jarak jauh tentang ini? Setting Load Balancing Dengan Metode Pcc Dan Failover Di Mikrotik

    dijawab ya!

    ReplyDelete
  2. Bisa. Teknisnya Pakai Tim Viewer dan Skype. Info W.A 081214518859

    ReplyDelete
  3. NOT WORK SDH SESUAI DENGAN YANG DI ATS

    ReplyDelete
  4. klo menurut ane script ke 5 salah !

    ReplyDelete
  5. ada yang kurang saya pahami, di semua new markrouting di MANGLE pake nama "to-wan**" sedangkan di IP ROUTE mark routing yg digunakan "jalur-wan**". Mohon pencerahan...
    ali.ichwan98@gmail.com
    089697767996 (WA)

    ReplyDelete
  6. saya ada tmbahan dengan LB ini,di settingan saya gunakan VPN,tapi dengan saya lakukan ada beberapa client yg bisa internet dan ada yg tidak bisa internet,semua berhasil.
    tapi saya ping dri VPN client k server yg ada LBnya connect,tetapi saya ping ke komputer yg terhbubung internet di LB nya tidak connect kira2 ada yg salah kah.

    ReplyDelete

Training Bulan ini

Padepokan IT

Jl. Ciuyah No.45 RT.05/RW.10 Bandung Barat 40551

Telp : 0812 8310 4119 (Telkomsel)
W.A : 081214518859 (WhatsApp)
Website : www.padepokanit.com
E-Mail : padepokanit.course@gmail.com
Instagram : @padepokanit

Info Site

User Online Padepokan-IT Course

IT Tutorial, Training & IT Solution