VIDEO TUTORIAL MIKROTIK ++225 VIDEO + MODUL TRAINING + SCRIPT

Jadwal Training Mikrotik Bulan ini 26,27,28 Juni (Basic-Mahir) 3 Hari Full

Jadwal Training Mikrotik Bulan ini  26,27,28 Juni (Basic-Mahir) 3 Hari Full
Lokasi : Graha Bukit Raya 1 Blok G3 No 16 Bandung Barat Telp 081214518859

Excel Fundamental, Excel Advanced, Dan Excel Programming VBA

IT TRAINING CENTER CONTACT : 0812 1451 8859 / 081 1219 8859

Kumpulan Script Regex Layer 7 Protocol Mikrotik untuk limit Video Streaming dan limit Download file

Pada tutorial kali ini penulis hanya akan memberikan kumpulan script Reguler Expression untuk dicoba silahkan coba satu persatu di mikrotik. Regular Expression (REGEX) adalah konstruksi bahasa untuk mencocokkan teks berdasarkan pola tertentu, terutama untuk kasus-kasus kompleks. Contoh misalkan mencari teks berawalan karakter tertentu, memiliki jumlah perulangan dari suatu teks, dan lain sebagainya.

Berikut Kumpulan Regex yang wajib dicoba di Mikrotik.
  1. Download File
  • ^.*get.+\.iso.*$
  • ^.*get.+\.exe.*$
  • ^.*get.+\.mp3.*$
  • \.(iso|exe|rar|pdf|mp3|mp4|3gp)
  • ^.*get.+\\.(exe|rar|zip|7z|cab|asf|mov|wmv|mpg|mpeg|mkv|avi|flv|pdf|
    wav|rm|mp3|mp4|ram|rmvb|dat|daa|iso|nrg|bin|vcd|mp2|3gp|mpe|qt|raw|wma|ogg|doc|deb
    |tar|bzip|gzip|gzip2|0[0-9][0-9]).*\$
    

  1. Video Streaming & Blocking Firewall
  • ^.+(youtube.com).*$  

  • ^.+(c.youtube.com|googlevideo.com|cdn.dailymotion.com|metacafe.com|mccont.com).*$
  • ^.*get.+(video|videoplayback|tube|youtube).*\$
    
  • ^.*get.+\\.(c.youtube.com|cdn.dailymotion.com|metacafe.com|mccont.com).*\$ 
  • ^.*(.*cdn[\d]{2,}.com|edge.telin.swiftserve.com|videos5.mediacorp.sg|cdn.yimg.com.*ts|akamaihd.net
    |rackspacecloud.com|stream.telin.swiftserve.com|nsimg.net|reftag|fbcdn.net\/hvideo.*|pdlvimeocdn-a.akamaihd.net|vimeocdn.com|googlevideo.com|dailymotion.com|metacafe.com
    |videos2.yjcontentdelivery.com|vt.tumblr.com|mccont.com|edge.liveleak.com
    |.*xvideos.com|phncdn.com|rncdn3.com|cloudfront.net|bangyoulater.com
    |wasumdo.sextgem.com|steamstatic.com|.*_all\/.*ts).*$
  • (get_video\\\?|videoplayback\\\?|videodownload\\\  \?|\\.flv\\\?|\\.fid\\\?)
    
  • http/(0\.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][0-9][\x09-\x0d -~]*(content-type: video) 
    
  • (get_video\?|videoplayback\?|videodownload\\?|\.flv\?|\.fid\?) 
     
    Atau yang ini r[0-9]+---[a-z]+-+[a-z0-9-]+\\.googlevideo\\.com  
     
     
    SCRIPT LIMIT STREAMING UPDATE 
     
    
    
  • ^.+(youtube).*\$|o-o.preferred.pttelkom- \A0 \\A0 \A0 
    
    \A0 \A0 \A0 \A0\A0 \A0 \A0 \A0 \A0 \A0 \A0 \A0 \A0 
    \A0 \A0 \A0 \\A0\A0|a.youtube.com|b.youtube.com|c.youtube.com
    \r\\n|d.youtube.com |e.youtube.com|f.youtube.com|\A0g.youtube.com|h.youtube.co\m
    |i.youtube.com\r\\n|j.youtube.com|l.youtube.com\94|
    (youtube.com).*\$ 
    
    
    Script Regex Blok FB : 
     
    ^.+(facebook.com).*$
    Sript Limit IDM
    get /.*(user-agent: mozilla/4.0|range: bytes=) 

    Sript Limit BITTORENT

    /ip firewall layer7-protocoladd
    name=situs.torrent
    regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|
    demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|
    bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|
    bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|
    commonbits).*\$"

    Sript Anti Brute Force
     
    Script 1 
     
    /ip firewall filter
    
    add chain=output comment="Drop FTP Brute Forcers" content=\
        "530 Login incorrect" dst-limit=1/1m,9,dst-address/1m protocol=tcp
    add action=add-dst-to-address-list address-list=FTP_BlackList \
        address-list-timeout=1d chain=output content="530 Login incorrect" \
        protocol=tcp
    add action=drop chain=input dst-port=21 protocol=tcp src-address-list=\
        FTP_BlackList

    SCRIPT 2
    /ip firewall filter
    add action=add-src-to-address-list address-list=SSH_BlackList_1 \
        address-list-timeout=1m chain=input comment=\
        "Drop SSH&TELNET Brute Forcers" connection-state=new dst-port=22-23 \
        protocol=tcp
    add action=add-src-to-address-list address-list=SSH_BlackList_2 \
        address-list-timeout=1m chain=input connection-state=new dst-port=\
        22-23 protocol=tcp src-address-list=SSH_BlackList_1
    add action=add-src-to-address-list address-list=SSH_BlackList_3 \
        address-list-timeout=1m chain=input connection-state=new dst-port=\
        22-23 protocol=tcp src-address-list=SSH_BlackList_2
    add action=add-src-to-address-list address-list=IP_BlackList \
        address-list-timeout=1d chain=input connection-state=new dst-port=\
        22-23 protocol=tcp src-address-list=SSH_BlackList_3
    add action=drop chain=input dst-port=22-23 protocol=tcp \
        src-address-list=IP_BlackList
     
    
Selamat Mencoba
 
Ingin Lebih Paham Tentang Mikrotik kami Sediautkan Video Tutorialnya
 

Info Video Tutorial Mikrotik Bisa dilihat disini
Training Private Mikrotik Running Setiap Bulan
Video Tutorial yang kami Buat Membahas Semua Fitur Mikrotik Mulai dari Tingkat Basic sampai dengan Mahir lebih dari 230 Video Materi Tutorial baik konsep dan Praktek.
Salam Padepokan IT
www.padepokanit.com
 
 
 
 
Share

Artikel Lainnya :



No comments:

Post a Comment

Training Bulan ini

Padepokan IT Course

Lokasi Training
1. Jl. Graha Bukit Raya 1 G3 No. 16 Bandung Barat
2. Jl. Ciuyah No.45 RT.05/RW.10 Bandung Barat

Telp : 081 1219 8859 (Telkomsel)
W.A : 081214518859 (WhatsApp)
Website : www.padepokanit.com
E-Mail : padepokanit.course@gmail.com
Instagram : @padepokanit

Info Site

User Online Padepokan-IT Course

IT Tutorial, Training & IT Solution